Mikrotik — обход блокировок Linkedin, Rutracker и Fast-torrent

Здравствуйте, мои маленькие любители открытого интернета и разумной цензуры. Сегодня мы с вами будем обходить блокировки Роскомнадзора с помощью Mikrotik`а и VPN. В моем примере будет рассмотрен вариант с PPTP, поэтому, если вы используете другой протокол, сделайте поправку на него.

Итак, у меня есть роутер Mikrotik, выступающий в качестве пограничного роутера, и vpn (pptp) учётка для авторизациина VPN сервере, находящемся в Европе. Начинаем настраивать.

Сначала создадим prerouting-правило в таблице Mangle (IP — Firewall — Mangle — Add new). Будем добавлять марку antiblock (через экшн mark routing) всем пакетам, исходящим из нашей локальной сети 192.168.88.0/24 и направляющихся на один из ip списка antiblock (в который мы чуть позже добавим адреса необходимых ресурсов).

Или в консоли:

 
/ip firewall mangle
add action=mark-routing chain=prerouting comment="AntiBlock Mark Routing" \
 dst-address-list=antiblock new-routing-mark=antiblock passthrough=no \
 src-address=192.168.88.0/24

Теперь идём в раздел Interfaces и создаем новый интерфейс необходимого типа с соответствующими настройками, в моём случае — PPTP Client. В качестве имени я укажу (для удобства) antiblock, а также заполню поля Connect To (адрес vpn-сервера), User (логин vpn) и Password (надеюсь, перевод не нужен 🙂 )

После заполнения нажимаем Apply и переходим во вкладку Status. Нас интересует, какой внутренний ip у vpn-сервера (Remote address) — он понадобится для создания маршрута. В моём случае адрес 10.0.0.254

Теперь создадим новый маршрут (IP — Routes — Add new). В качестве Dst. Address оставим 0.0.0.0/0, в качестве Gateway укажем внутренний ip-адрес vpn-сервера (который мы подсмотрели в статусе vpn-интерфейса). И обязательно укажем Routing mark, которую мы задали в Mangle-правиле (тоже antiblock),

Или в консоли:

 
/ip route
add distance=1 gateway=10.0.0.254 routing-mark=antiblock

Теперь добавим ip заблокированных хостов в адресный лист antiblock, который мы указали в качестве  Dst. Address List Mangle-правила. Можно добавить их вручную через IP — Firewall — Address List, но т.к. их много — приведу сразу консольные команды для терминала.

Добавляем ip Linkedin:

 
/ip firewall address-list add list=antiblock address=216.3.18.0/24
/ip firewall address-list add list=antiblock address=8.39.53.0/24
/ip firewall address-list add list=antiblock address=8.22.121.0/24
/ip firewall address-list add list=antiblock address=65.156.227.0/24
/ip firewall address-list add list=antiblock address=209.119.43.0/24
/ip firewall address-list add list=antiblock address=216.52.16.0/21
/ip firewall address-list add list=antiblock address=216.52.22.0/24
/ip firewall address-list add list=antiblock address=216.52.18.0/24
/ip firewall address-list add list=antiblock address=216.52.16.0/24
/ip firewall address-list add list=antiblock address=216.52.20.0/24
/ip firewall address-list add list=antiblock address=144.2.232.0/24
/ip firewall address-list add list=antiblock address=144.2.233.0/24
/ip firewall address-list add list=antiblock address=144.2.236.0/24
/ip firewall address-list add list=antiblock address=144.2.237.0/24
/ip firewall address-list add list=antiblock address=144.2.224.0/24
/ip firewall address-list add list=antiblock address=144.2.228.0/24
/ip firewall address-list add list=antiblock address=144.2.225.0/24
/ip firewall address-list add list=antiblock address=144.2.229.0/24
/ip firewall address-list add list=antiblock address=144.2.22.0/24
/ip firewall address-list add list=antiblock address=144.2.21.0/24
/ip firewall address-list add list=antiblock address=70.42.142.0/24
/ip firewall address-list add list=antiblock address=208.203.151.0/24
/ip firewall address-list add list=antiblock address=208.50.161.0/24
/ip firewall address-list add list=antiblock address=108.174.14.0/24
/ip firewall address-list add list=antiblock address=108.174.15.0/24
/ip firewall address-list add list=antiblock address=103.20.92.0/24
/ip firewall address-list add list=antiblock address=103.20.93.0/24
/ip firewall address-list add list=antiblock address=108.174.13.0/24
/ip firewall address-list add list=antiblock address=108.174.0.0/20
/ip firewall address-list add list=antiblock address=108.174.1.0/24
/ip firewall address-list add list=antiblock address=108.174.4.0/24
/ip firewall address-list add list=antiblock address=108.174.5.0/24
/ip firewall address-list add list=antiblock address=108.174.6.0/24
/ip firewall address-list add list=antiblock address=108.174.7.0/24
/ip firewall address-list add list=antiblock address=108.174.8.0/24
/ip firewall address-list add list=antiblock address=108.174.9.0/24
/ip firewall address-list add list=antiblock address=108.174.10.0/24
/ip firewall address-list add list=antiblock address=108.174.11.0/24
/ip firewall address-list add list=antiblock address=108.174.12.0/24
/ip firewall address-list add list=antiblock address=108.174.0.0/23
/ip firewall address-list add list=antiblock address=108.174.2.0/23
/ip firewall address-list add list=antiblock address=108.174.4.0/23
/ip firewall address-list add list=antiblock address=108.174.6.0/23
/ip firewall address-list add list=antiblock address=108.174.8.0/23
/ip firewall address-list add list=antiblock address=108.174.10.0/23
/ip firewall address-list add list=antiblock address=108.174.12.0/23
/ip firewall address-list add list=antiblock address=108.174.14.0/23
/ip firewall address-list add list=antiblock address=108.174.0.0/22
/ip firewall address-list add list=antiblock address=108.174.4.0/22
/ip firewall address-list add list=antiblock address=108.174.8.0/22
/ip firewall address-list add list=antiblock address=108.174.12.0/22
/ip firewall address-list add list=antiblock address=108.174.0.0/21
/ip firewall address-list add list=antiblock address=108.174.8.0/21
/ip firewall address-list add list=antiblock address=199.101.161.0/24
/ip firewall address-list add list=antiblock address=64.152.25.0/24
/ip firewall address-list add list=antiblock address=103.20.95.0/24
/ip firewall address-list add list=antiblock address=185.63.147.0/24
/ip firewall address-list add list=antiblock address=185.63.145.0/24
/ip firewall address-list add list=antiblock address=185.63.144.0/24
/ip firewall address-list add list=antiblock address=144.2.0.0/24
/ip firewall address-list add list=antiblock address=103.20.94.0/24
/ip firewall address-list add list=antiblock address=144.2.2.0/24
/ip firewall address-list add list=antiblock address=144.2.1.0/24
/ip firewall address-list add list=antiblock address=8.22.161.0/24
/ip firewall address-list add list=antiblock address=144.2.192.0/24
/ip firewall address-list add list=antiblock address=204.2.228.0/24
/ip firewall address-list add list=antiblock address=144.2.3.0/24
/ip firewall address-list add list=antiblock address=185.63.145.0/24
/ip firewall address-list add list=antiblock address=144.2.194.0/24
/ip firewall address-list add list=antiblock address=144.2.193.0/24
/ip firewall address-list add list=antiblock address=144.2.195.0/24
/ip firewall address-list add list=antiblock address=144.2.7.0/24
/ip firewall address-list add list=antiblock address=103.20.93.0/24
/ip firewall address-list add list=antiblock address=103.20.95.0/24
/ip firewall address-list add list=antiblock address=204.2.228.0/24
/ip firewall address-list add list=antiblock address=144.2.3.0/24
/ip firewall address-list add list=antiblock address=64.74.98.0/24
/ip firewall address-list add list=antiblock address=208.111.169.0/24
/ip firewall address-list add list=antiblock address=199.101.160.0/24
/ip firewall address-list add list=antiblock address=108.174.2.0/24
/ip firewall address-list add list=antiblock address=108.174.3.0/24
/ip firewall address-list add list=antiblock address=91.225.248.0/24
/ip firewall address-list add list=antiblock address=91.225.249.0/24
/ip firewall address-list add list=antiblock address=91.225.250.0/24

 

Добавляем ip Rutracker:

/ip firewall address-list add list=antiblock address=78.154.153.0/24
/ip firewall address-list add list=antiblock address=195.82.146.0/24

 

Добавляем ip Fast-torrent:

/ip firewall address-list add list=antiblock address=5.45.71.49

 

И для особо страждущих — добавляем ip PornHub`а (чтобы не запрашивал авторизацию через вконтакте как для российских ip)

/ip firewall address-list add list=antiblock address=66.254.114.41

В интерфейсе после добавления выглядит вот так:

Осталось только добавить маскарадинг для vpn-интерфейса. Создаем новое NAT-правило для цепочки srcnat (IP — Firewall — NAT — Add new), в Out.Interface укажем наш интерфейс vpn, а в Action укажем masquerade.

Или в консоли:

/ip firewall nat add action=masquerade chain=srcnat comment=Masquerade out-interface=antiblock

Готово.

Теперь при обращении к одному из заблокированных ресурсов, чей ip внесен в соответствующий список на Микротике, пакеты отмаркируются и, в соответствии с таблицей маршрутизации этой маркировки, уйдут через vpn-канал.

Leave a Reply

Ваш e-mail не будет опубликован. Обязательные поля помечены *